Confirmed Mass Recruit Broken

Discussion in 'Browser Issue Archive' started by iksnumskaw, Dec 14, 2016.

  1. iksnumskaw

    iksnumskaw Archer

    Joined:
    Jun 23, 2016
    Messages:
    154
    Likes Received:
    44
    Every time I go to mass recruit, it says I am already mass recruiting and will not work. I have tried logging out, clearing my cache, and also trying a different browser. Still doesn't work. Anyone else having this issue??
     
  2. kikicaylan

    kikicaylan Paladin

    Joined:
    Nov 25, 2015
    Messages:
    840
    Likes Received:
    293
    There is something wrong with the mass recruit at this time, developers are working on fixing it. :(
     
  3. Angry Cupcake

    Angry Cupcake Spearman

    Joined:
    Nov 30, 2016
    Messages:
    1
    Likes Received:
    0
    I had this problem for a month and was corresponding with support about it, and two days ago it suddenly started working again. I had tried everything previously to try to make it work and had no luck, but I did absolutely nothing different when it actually did start functioning again.
     
  4. DeChantal

    DeChantal Swordsman

    Joined:
    Dec 6, 2015
    Messages:
    66
    Likes Received:
    50
    Thank you for that update Angry Cupcake, appreciate that and glad to hear it. :) As Kiki mentioned, this is something that has been under review and hopefully be corrected for all soon.
    For those that it may not be working for currently - you can still recruit by going to individual villages. I know this is not ideal, but that is a way to do it until the mass recruit is available.
     
    Coolnite7 likes this.
  5. pumanchero

    pumanchero Spearman

    Joined:
    Aug 30, 2016
    Messages:
    39
    Likes Received:
    3
    The issue is alive again. I'm using Google Chrome for reference. I'm sure you already have received tickets about it, I'm just joining the popular clamor to fix it :p
     

Share This Page