Release 1.90 and 1.91

cokky

Berserker
seems to be an error in the city search where it is flashing and not seeing the numbers letters pushed properly a few players have complained in game about it mostly on PC.
 

Management

Berserker
So other than some iOS fixes, we get email validation and new colors. Was anyone really concerned about the way the inventory worked?? LOL. Why spend time/money on such frivolous things when they could be improving gameplay o_O

You can polish a turd all you want Inno... at the end of the day it's still a turd.

**Actual behind the scenes footage of Inno Devs updating TW2!**

 
Last edited:

Beezkneez

Tribal Wars 2 Team
You can polish a turd all you want Inno... at the end of the day it's still a turd.
I believe the correct quote is: "It doesn't matter how long you polish a turd, it's never going to shine."

Nice Idiocracy clip though. Oh the times we live in; square pegs and round holes. o_O
 
This update was actually a setback to the game. They ruined everyone's main form of communication. You cant even link players or buildings that have a space in the name (example: shiny turd). How are tribal ops supposed to happen when you can't even link villages? This isn't even going into the debacle on how copy+pasting messages in game are now completely screwed up.
 

Beezkneez

Tribal Wars 2 Team
Where is Kiki hiding? :confused:

I'm pretty sure BahamaLlama that you cannot name a village with the word *turd*. I believe one update they did was restricting names you're allowed to use on villages. I tried to name a village 'Down the Rabbit Hole' in game and an error message came up. I'm like...OK, well....nice to find that out.