Severe General Bugginess

Syvarius

Spearman
Since I started playing this game a couple of months ago I have witnessed severe buggy errors on numerous occasions, far too many to count really, and I am starting to think this game might be a top contender for the buggiest game ever award.

Let's start with the normal problems, the ones that occur daily if not hourly: 1. Windows (message, tribe, forums, attack command, presets etc.) fail to load properly and game must be reloaded. This happens to me all the time. Sometimes reloading will not work until 2 or 3 tries later or it will freeze up while reloading. 2. When farming, troops often do not show as dispatched after using the hotkey attack commands on target villas for a long time after, or, in some cases, must reload for commands to show. 3. Map fails to load properly / glitches in the map (usually pretty minor). 4. Random "route not public" and other error messages occurring when trying to execute perfectly valid commands.

Less common errors glitches I have noticed: 1. The in-game messaging system either not working properly, very slowly, or failing to work altogether. Regarding this: whoever designed the messaging system is apparently terrible at their job, as it is the most glitchy message system I have ever used, and it should be a simple tool. Also, why in the world would the hotkeys be designed to function when the messaging windows are open? The last thing you want to have happen is the system to all of a sudden decide (on its own) that you are no longer typing in the message but pressing hotkeys, then it starts opening other windows and you lose your message. This has happened to me COUNTLESS times, thankfully only a dozen or so I actually lost any meaningful messages, but it has been very annoying when it happened, having to re-link players, villages, etc.. into my message. 2. The game not allowing me to log in at all.
3. The system glitch that just occurred and prompted this comment; I was relocating 40 catapults from my main village to another village, I was on the relocate screen and the target village had 1000+ provisions and the provisions of 40 catapults is something like 380 and I was like "ok, relocate". Well the command went through and off go the catapults, only thing is?... The provisions that should have been freed up in my main - still apparently used. It still showed 0 provisions in my main. I checked the other villa, sure enough, it has 380 less provisons as a result of the incoming relocating catapults. SOO... I reload twice. No change. Try to cancel the relocation order and get told I can't because I don't have enough provisions in target village. In other words, because my main lacked the provisions to take back in units IT WAS JUST HOUSING less than two minutes earlier, and which, according to the provisions used in my main, were, in fact, still housed there.

The reason I am making this thread is to point out to game development that this is not a sustainable game model. I personally loved the game when I got into it (not that long ago), and am still fond of it, but I am finding it less and less bearable daily as a result of the constant bugginess. The other day I was trying to time out some important strikes and the attack button failed to work at all when I needed to launch, I had timed everything down to the seconds, so failing to launch on time was a potential disaster, as nobles had already been launched and thanks to game bugginess the main nuke ended up being due to land behind the nobles. In most cases that would have been a disaster, but fortunately in that case, other factors allowed it to still play out in our favor. Still, such glitches jeoporadize the integrity of the game and ruin the playing experience for everyone, not to mention undermine the effectiveness of a serious strategy game that prides itself on its depth and precision. You guys consistently come out with new patches, and yet none of these underlying system failures or bad code issues seem to get addressed. The system itself remains as buggy as ever, and I know I, for one, am getting very tired of it.

The sad thing is, I think this has the potential to be a really great game, but these issues are making me lose faith and question whether I want to continue playing. I have been contemplating starting a new world but am questioning whether I want to make any commitment to playing the game any longer. I have spent money on this game, nothing major, but a good chunk. I will definitely not be spending anymore as it seems the money the players spend in this game doesn't even go back into improving the system. At least not what I can tell from the time I have been playing.

INNOGames: if you want to make money and be a successful game developer, you need to deliver games that are solid and reliable. Games a customer can feel are a worthy product that they can truly enjoy. Otherwise you will just be another failed game developer within the next decade. Not trying to be harsh, just realistic.

Sincerely, a frustrated TW2 fan/gamer
 

elphame

Mounted Archer
Try doing a dodge and snipe only to have the server issues count seconds by 2-4 and go back in time on occasion. Lost a few vills that shouldn't have been lost due to this :(
 

Babygrrrrl

Spearman
From personal experience...

There are some common ways to fix most of those issues. Clear your cache - especially if you're using Chrome. Try a different browser - Chrome and Firefox seem to work best so if you switch to one of those then it COULD clear up those problems.

If you've done that, then put in a support ticket in the game and let the mods know you tried clearing your cache and tried both Chrome and Firefox. They'll be able to take it from there.
 

Syvarius

Spearman
Yea I have tried different browsers, Firefox seems to work best but does still have some issues. The glitch with the provisions did seem to clear itself up but not till several hours later but it seems like those "ghost" provisions came back to me. I have tried clearing my cache but it is true it is probably overdue for another clearing. I know some of it can be dealt with on my end perhaps but nonetheless the server and internal system of the game itself does seem rather buggy sometimes.

On a positive note, it has actually been running rather well for me since the 1.76 update so it looks like some real improvements might actually be happening in that area, bravo!

I went ahead and started on the new world anyway and while it glitched out initially during setup (wouldn't let me go to the world map, even after relog, but finally worked a day later) it's been working very well since and US20 too, I just hope it keeps up.

I will clear my cache again, see if that helps, it has been a bit.
 

ayoshi

Spearman
In response to your issue about shipping out the catapults, #1, it should be 320 provisions for 40, not 380. However, are you certain that you were not in negative provisions when you sent the catapults away? Think about this, say someone catted down your farm while your troops were out on an attack. With a level 30 farm, you have 24000 total provisions, with 20000 provisions of troops, so you have about 2000 "extra" provisions (after taking building population into account).
They cat down your farm, leaving you with a lvl 29 farm. This leaves you with a total of 20,476 provisions, but now, since you still have about 2000 provisions for your building population, you actually have about negative 1500 provisions because of the loss of the farm. You could send the 40 cats to another village, thereby transferring that provision cost to the other village (thus, it would drop), however, you would still be at over negative 1100 provisions in your first village. Since the screen does not show negative crop, you would see this as having "zero" provisions" still.